Verification Codes/ Password Reset Emails Delayed

Incident Report for GameChanger

Resolved

The incident has been resolved. Login codes and forgot password emails should arrive normally. We will continue to monitor for any further issues.
Posted May 12, 2026 - 11:43 EDT

Update

Login codes or forgot password emails may be delayed or not received. We are working with our email vendor and do not believe this is caused by GameChanger systems. Try “Resend code” if you do not receive a code or re-attempt the "forgot password" process.
Posted May 11, 2026 - 16:18 EDT

Investigating

Login codes or forgot password links sent via email are being sometimes delayed or not received. Try waiting if possible or hitting "Resend code" if you do not get a code. We are investigating root cause now and will update when we have more information.
Posted May 11, 2026 - 15:01 EDT
This incident affected: Login and Account Access.