Email notifications may be delayed
Incident Report for GameChanger
Resolved
We encountered an issue with our email provider that was causing email delivery to be delayed. This has now been resolved.
Posted Aug 28, 2023 - 09:47 EDT
Update
We are continuing to investigate this issue.
Posted Aug 27, 2023 - 16:16 EDT
Investigating
We are experiencing problems sending emails. Receiving login links from web.gc.com, team announcements, schedule changes, and RSVP reminders may be delayed.
Posted Aug 27, 2023 - 15:40 EDT
This incident affected: GC.com and SMS and Email Alerts.