web.gc.com authentication down
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 16:37 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 03, 2024 - 16:17 EST
Investigating
We are currently investigating an issue where authentication to web.gc.com is unavailable.
Posted Jan 03, 2024 - 16:09 EST
This incident affected: GC.com and Payments and Billing.