Google Play Subscriptions are not processing
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 16:38 EDT
Identified
We are currently experiencing issues processing subscriptions with the Google Play Store. Do not attempt to retry purchasing a subscription. Our engineers are working to fix the issue.
Posted Apr 22, 2022 - 16:01 EDT
This incident affected: Payments and Billing.