Video and Notifcation Issues
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Jun 10, 2023 - 14:25 EDT
Update
We are continuing to investigate this issue.
Posted Jun 10, 2023 - 11:45 EDT
Update
We are continuing to investigate this issue.
Posted Jun 10, 2023 - 10:57 EDT
Investigating
We are currently investigating this issues
Posted Jun 10, 2023 - 08:21 EDT
This incident affected: GC.com, GameChanger App API, Live GameStream Updates, and SMS and Email Alerts.