Web Subscription Purchases Temporarily Unavailable

Incident Report for GameChanger

Resolved

The issue has been resolved and web subscriptions are now available. Thanks for your patience!
Posted Jan 25, 2026 - 18:26 EST

Investigating

New web subscription purchases are temporarily unavailable. Our teams are actively working on a fix and will share updates as soon as service is restored. Thanks for your patience!
Posted Jan 25, 2026 - 16:51 EST
This incident affected: Payments and Billing.