Issues with GameChanger app
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Sep 25, 2023 - 13:18 EDT
Update
We are continuing to investigate this issue.
Posted Sep 25, 2023 - 12:40 EDT
Investigating
We are currently investigating slowness and connection errors in the GC app which may result in the inability to log in or navigate within both the iOS and Android apps.
Posted Sep 25, 2023 - 12:39 EDT
This incident affected: Payments and Billing, GameChanger App API, Live GameStream Updates, Stat Calculation, and Game Recap Stories.