GC App Functional Intermittently Unavailable

Incident Report for GameChanger

Resolved

This incident has been resolved.
Posted Sep 22, 2025 - 13:47 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2025 - 13:32 EDT

Investigating

We’re currently experiencing issues with some parts of the GameChanger app. Our engineering team is actively investigating and working to resolve the problem. We appreciate your patience and will provide updates as we learn more.
Posted Sep 22, 2025 - 13:24 EDT
This incident affected: GameChanger App.