GameChanger Classic email game alerts may be delayed
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Apr 14, 2022 - 13:33 EDT
Investigating
Game start and end email alerts on GameChanger Classic may be delayed. Our engineers are working with our email provider to investigate the cause of the issue.
Posted Apr 13, 2022 - 21:12 EDT
This incident affected: SMS and Email Alerts.