GameChanger Degraded Performance with Apple Subscriptions
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 22:02 EST
Investigating
We are currently investigating this issue.
Posted Jan 20, 2023 - 20:56 EST
This incident affected: Payments and Billing.