Team Search

Incident Report for GameChanger

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 13:40 EDT

Update

We’re currently experiencing degraded performance with Team Search. Users may notice slower load times or incomplete results while searching for teams.
Our team is actively investigating the issue and working to restore full functionality as quickly as possible. We’ll provide updates as soon as more information becomes available.
Posted Mar 10, 2026 - 12:57 EDT

Investigating

We’re currently experiencing degraded performance with Team Search. Users may notice slower load times or incomplete results while searching for teams.
Our team is actively investigating the issue and working to restore full functionality as quickly as possible. We’ll provide updates as soon as more information becomes available.
Posted Mar 10, 2026 - 12:53 EDT
This incident affected: Search (Team, Leagues or Tournaments).