GC App Slowness
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Jun 03, 2023 - 23:44 EDT
Identified
The application should now be loading normally. There may still be delays in receiving updates for live games.
Posted Jun 03, 2023 - 13:54 EDT
Investigating
We are investigating slow loading and delayed updates in the GC app
Posted Jun 03, 2023 - 11:36 EDT
This incident affected: GameChanger App API and Live GameStream Updates.