Web Subscription Processing Issues

Incident Report for GameChanger

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 11:16 EDT

Identified

At this time, payment processing for web subscriptions is down. Users will be unable to purchase subscriptions on the web. Web subscription renewals will be delayed but will not affect subscription access.
Posted Aug 18, 2026 - 10:57 EDT
This incident affected: Payments and Billing.