Emails for team announcements and schedule updates may be delayed
Incident Report for GameChanger
Resolved
Emails for team announcements and schedule updates are now operating normally. Please contact support if you continue to experience issues.
Posted Aug 07, 2020 - 00:00 EDT
Investigating
We are currently investigating the issue with our third-party email provider.
Posted Aug 06, 2020 - 23:24 EDT
This incident affected: SMS and Email Alerts.