Live streaming degradation
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Aug 16, 2022 - 15:37 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2022 - 15:37 EDT
Investigating
We are currently investigating this issue.
Posted Aug 16, 2022 - 14:49 EDT
This incident affected: Live GameStream Updates.