Platform Performance Issues

Incident Report for GameChanger

Resolved

The issue impacting platform performance has been resolved. All features, including live streams, recaps, video, and schedule functionality, are now operating normally.

We appreciate your patience while our team worked to get you back in the game!
Posted Apr 24, 2026 - 19:20 EDT

Monitoring

We appreciate your patience while our teams are working hard to get you back in the game! Performance is stabilizing platform wide.
Posted Apr 24, 2026 - 19:05 EDT

Investigating

We’re currently experiencing an outage affecting various features. Users may encounter slow load times or be unable to access live streams, recaps, video tabs, and portions of the schedule.

Our team is actively investigating and working to restore full functionality as quickly as possible. We’ll provide updates here as more information becomes available.
Posted Apr 24, 2026 - 18:28 EDT
This incident affected: Video Streaming & Viewing, Event Creation & Scheduling, and Game Recap Stories.