GameChanger App Experiencing Degraded Performance
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted May 05, 2024 - 11:23 EDT
Investigating
We are currently investigating this issue
Posted May 05, 2024 - 11:13 EDT
This incident affected: GameChanger App API, Live GameStream Updates, Stat Calculation, and Game Recap Stories.