Degraded Performance of Live GameStream Updates
Incident Report for GameChanger
Resolved
Live GameStream Updates are now operating normally. Please contact support if you continue to experience issues.
Posted Nov 11, 2022 - 19:11 EST
Investigating
Live GameStream Updates are experiencing performance issues. You may experience duplicated play information and incorrect scoreboard data. Our engineers are investigating the cause of the issue.
Posted Nov 11, 2022 - 18:03 EST
This incident affected: Live GameStream Updates.