Issues with video streaming and viewing recording post game

Incident Report for GameChanger

Resolved

Issue resolved for all users experiencing issues stopping a stream and seeing populated video archives postgame.
Posted Jun 26, 2025 - 15:32 EDT

Identified

An issue with video recordings and the live tile was identified at 2:08 pm ET and a fix was immediately identified. We are deploying a fix right now and this should be resolved by approximately 4:00 pm ET. Users will be unable to end a running stream and also unable to start a new stream if they had previously tried to end it and failed. Archive videos will not populate after the game until this is resolved and all recordings are backfilled.
Posted Jun 26, 2025 - 15:15 EDT
This incident affected: Video Streaming & Viewing.