GC Classic Degraded
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Apr 29, 2022 - 20:59 EDT
Investigating
GC Classic mobile apps and website are having intermittent connection issues. We are investigating.
Posted Apr 29, 2022 - 19:18 EDT
This incident affected: GC.com and GameChanger Classic App API.