Intermittent issues as a result of broader Amazon Web Services (AWS) outages

Incident Report for GameChanger

Resolved

This incident has been resolved
Posted Oct 20, 2025 - 17:20 EDT

Update

All Systems are fully operational!
Posted Oct 20, 2025 - 17:17 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:50 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:36 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:30 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 13:23 EDT

Investigating

We are monitoring this situation and waiting on further updates from AWS.
Posted Oct 20, 2025 - 11:38 EDT
This incident affected: Login and Account Access, Video Streaming & Viewing, Messaging and Notifications, Third-Party Integrations, GameChanger App, and Game Recap Stories.