GameChanger Degraded Performance
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Apr 18, 2023 - 20:51 EDT
Investigating
We are currently investigating this issue.
Posted Apr 18, 2023 - 19:02 EDT
This incident affected: GameChanger App API, Live GameStream Updates, SMS and Email Alerts, and Game Recap Stories.