Email notifications are currently degraded
Incident Report for GameChanger
Resolved
3rd party email provider is back online.
Posted Nov 02, 2023 - 09:37 EDT
Update
Mandrill
Posted Nov 02, 2023 - 09:33 EDT
Investigating
Email notifications are currently degraded. Our engineers are investigating the cause of the issue.
Posted Nov 02, 2023 - 09:26 EDT
This incident affected: SMS and Email Alerts.