Issues Adding Players to Teams
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Oct 25, 2023 - 13:59 EDT
Investigating
We apologize, but we are currently experiencing issues trying to add players to teams and are investigating.
Posted Oct 25, 2023 - 11:23 EDT
This incident affected: GC.com and GameChanger App API.