Android App experiencing game sync issues
Incident Report for GameChanger
Resolved
The Android app is fully functional. Please contact support if you continue to experience issues.
Posted about 1 year ago. Jun 06, 2017 - 22:46 EDT
Identified
We have identified the cause of our Android game sync and our engineers are working to fix it.
Posted about 1 year ago. Jun 06, 2017 - 22:24 EDT