GameChanger is experiencing overall site slowness
Incident Report for GameChanger
Resolved
Website and app performance should now be normal. Please contact support if you continue to experience issues.
Posted Oct 06, 2019 - 11:03 EDT
Investigating
GameChanger is experiencing slow response times throughout our site. You may be noticing longer than normal load times on many pages. Our engineers are investigating to bring speeds back to normal.
Posted Oct 06, 2019 - 09:56 EDT
This incident affected: GC.com, Baseball and Softball App API, Live GameStream Updates, and Stat Calculation.