Apple Payments are not processing
Incident Report for GameChanger
Resolved
Payment processing and access to billing info should be back to normal. If you continue to experience issues please contact support.
Posted Jan 24, 2020 - 15:52 EST
Monitoring
Apple iTunes payments are now successful. Our engineers continue to monitor for intermittent issues processing payments and updates to billing info. If you experience a payment failure please try again. If you continue to have trouble with payments please contact support.
Posted Jan 24, 2020 - 14:03 EST
Identified
We are currently experiencing issues processing payments with Apple iTunes. You may experience delayed payment processing or failure of your charge to process. Our engineers are working to fix the issue. If you experience continued payment failures please contact customer support.
Posted Jan 24, 2020 - 11:09 EST
This incident affected: Payments and Billing.