Email notifications may be delayed
Incident Report for GameChanger
Resolved
All backlogged emails have now been sent. Thank you for your patience and apologies for the inconvenience.
Posted 3 months ago. May 24, 2018 - 16:46 EDT
Update
We are continuing to work on a fix for this issue. While many of your emails are being sent, some are still delayed. We appreciate your patience and understanding.
Posted 3 months ago. May 24, 2018 - 15:33 EDT
Identified
We are experiencing problems sending emails for team announcements, schedule changes, and RSVP reminders. We are working on a fix and apologize for the delays.
Posted 3 months ago. May 24, 2018 - 13:32 EDT