Email alerts may be delayed
Incident Report for GameChanger
Resolved
This issue has been resolved.
Posted 3 months ago. Aug 26, 2018 - 21:51 EDT
Monitoring
We have identified the cause of email alert delays. There are some issues with our third party provider and our engineers are monitoring the situation.
Posted 3 months ago. Aug 26, 2018 - 21:07 EDT
This incident affected: SMS and Email Alerts.