Degraded Performance of app and website
Incident Report for GameChanger
Resolved
The iOS app is fully functional. Please contact support if you continue to experience issues.
Posted about 1 year ago. Jun 11, 2017 - 16:29 EDT
Update
We are narrowing down what part of the system is experiencing performance issues which is causing app and website slowness.
Posted about 1 year ago. Jun 11, 2017 - 15:00 EDT
Investigating
The app and website are experiencing performance issues. You may experience GameStream and notification delays. Our engineers are investigating the cause of the issue.
Posted about 1 year ago. Jun 11, 2017 - 13:54 EDT