Email alerts may be delayed
Incident Report for GameChanger
Resolved
Email alerts are now being sent normally. Please contact support if you continue to experience issues.
Posted Mar 02, 2020 - 11:48 EST
Identified
We have identified the cause of email alert delays. Our engineers are working on a fix for the issue.
Posted Mar 02, 2020 - 10:59 EST
This incident affected: SMS and Email Alerts.