Email alerts may be delayed
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted 24 days ago. May 02, 2019 - 18:00 EDT
Update
We are continuing to monitor for any further issues.
Posted 24 days ago. May 02, 2019 - 17:59 EDT
Monitoring
Email alerts are delayed, but we are monitoring the issue.
Posted 24 days ago. May 02, 2019 - 15:26 EDT
This incident affected: SMS and Email Alerts.