Team Manager App Game Alerts may be delayed
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted May 01, 2021 - 14:17 EDT
Investigating
We are currently investigating this issue.
Posted May 01, 2021 - 13:23 EDT
This incident affected: Team Manager App API.