Some game alerts may be delayed
Incident Report for GameChanger
Resolved
Game and team alerts are now being sent normally. Please contact support if you continue to experience issues.
Posted 11 months ago. Jan 22, 2018 - 13:05 EST
Investigating
Some game alerts are delayed. Our engineers are investigating the cause of the issue.
Posted 11 months ago. Jan 22, 2018 - 11:58 EST