GameChanger is experiencing overall site slowness and outages
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 13, 2019 - 10:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Jul 13, 2019 - 10:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Jul 13, 2019 - 10:44 EDT
Investigating
GameChanger is experiencing slow response times and/or outages throughout our site. You may be noticing longer than normal load times on many pages. Our engineers are investigating to bring speeds back to normal.
Posted about 1 month ago. Jul 13, 2019 - 10:41 EDT
This incident affected: GC.com and Stat Calculation.