GameChanger live GameStream experience is experiencing slowness
Incident Report for GameChanger
Resolved
GameStream performance should now be normal. Please contact support if you continue to experience issues.
Posted 9 months ago. May 21, 2017 - 20:52 EDT
Monitoring
Performance of the live GameStream should be restored. We continue to monitor the situation for any additional slowness.
Posted 9 months ago. May 21, 2017 - 20:38 EDT
Investigating
GameChanger is experiencing slow response times on the live game experience. You may be noticing longer than normal load times on the live game pages pages. Our engineers are investigating to bring speeds back to normal.
Posted 9 months ago. May 21, 2017 - 20:32 EDT