Team Manager Degraded Performance
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted May 15, 2021 - 15:53 EDT
Update
We are continuing to investigate this issue.
Posted May 15, 2021 - 15:51 EDT
Update
Incident resolved
Posted May 15, 2021 - 15:50 EDT
Update
We are continuing to investigate this issue.
Posted May 15, 2021 - 15:49 EDT
Investigating
We are currently investigating this issue.
Posted May 15, 2021 - 14:23 EDT
This incident affected: Team Manager App API and Live GameStream Updates.