GameChanger Baseball and Softball Website Service Issues
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Aug 14, 2020 - 10:46 EDT
Update
We are continuing to investigate this issue.
Posted Aug 14, 2020 - 10:45 EDT
Investigating
Our engineers are currently investigating an issue that will impact our GameChanger Baseball and Softball Website. If you experience problems with our service please contact customer support at help@gc.com
Posted Aug 14, 2020 - 10:25 EDT
This incident affected: GC.com, Baseball and Softball App API, Team Manager App API, Live GameStream Updates, Stat Calculation, SMS and Email Alerts, Game Recap Stories, and Payments and Billing.