Game/player alerts and all stats calculations are experiencing delays
Incident Report for GameChanger
Resolved
We have deployed a fix and game/player alerts should be operational and stat calculations should be up to date
Posted 8 months ago. Apr 11, 2018 - 18:11 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 8 months ago. Apr 11, 2018 - 18:02 EDT