Degraded Performance of Team Manager Search
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted May 15, 2021 - 20:16 EDT
Update
We're continuing to investigate the root cause of this issue
Posted May 15, 2021 - 18:19 EDT
Investigating
We are currently investigating this issue.
Posted May 15, 2021 - 17:13 EDT
This incident affected: Team Manager App API.