Email alerts may be delayed
Incident Report for GameChanger
Resolved
Email alerts have been resolved.
Posted 29 days ago. Apr 27, 2019 - 19:05 EDT
Monitoring
A fix is implemented and we are monitoring the results.
Posted 29 days ago. Apr 27, 2019 - 19:00 EDT
Investigating
Email alerts are delayed. Our engineers are investigating the cause of the issue.
Posted 29 days ago. Apr 27, 2019 - 18:45 EDT
This incident affected: SMS and Email Alerts.