Email alerts may be delayed
Incident Report for GameChanger
Resolved
Email alerts are now being sent normally. Please contact support if you continue to experience issues.
Posted over 1 year ago. Mar 30, 2017 - 17:05 EDT
Update
We are still investigating this issue with our email service provider. We will provide an update once email alerts are working once again.
Posted over 1 year ago. Mar 30, 2017 - 16:33 EDT
Investigating
Email alerts are delayed. Our engineers are investigating the cause of the issue.
Posted over 1 year ago. Mar 30, 2017 - 15:43 EDT