TeamManager App experiencing sync and connectivity issues
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 19:40 EDT
Investigating
We are having sync latency on our Team Manager app. App may experience delayed live updates and changes.
Posted Jun 24, 2020 - 19:09 EDT
This incident affected: Team Manager App API and Live GameStream Updates.