Team Manager App In Maintenance
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 06:05 EST
Investigating
We are currently investigating this issue.
Posted Mar 10, 2021 - 05:06 EST
This incident affected: Team Manager App API.