GameChanger Service Issues
Incident Report for GameChanger
Resolved
GameChanger is now operating normally. Please contact support if you continue to experience issues.
Posted about 1 year ago. May 28, 2017 - 09:25 EDT
Monitoring
Our engineers have implemented a fix for the reported issues. We are continuing to monitor performance as the fix takes effect.
Posted about 1 year ago. May 28, 2017 - 09:14 EDT
Investigating
Our engineers are currently investigating an issue that may impact some GameChanger functionality. If you experience problems with our service please contact customer support at help@gc.com
Posted about 1 year ago. May 28, 2017 - 08:59 EDT