Degraded Performance of the Application
Incident Report for GameChanger
Resolved
Website performance should now be normal. Please contact support if you continue to experience issues.
Posted 6 months ago. Jun 06, 2018 - 20:37 EDT
Identified
We have identified the cause of longer than normal load times throughout the site. Our engineers are working on a fix to bring speeds back to normal.
Posted 6 months ago. Jun 06, 2018 - 20:06 EDT
Investigating
The application is experiencing performance issues. Our engineers are investigating the cause of the issue.
Posted 6 months ago. Jun 06, 2018 - 19:53 EDT