Issues with Subscription Purchases on the Website
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted 21 days ago. Jul 02, 2019 - 10:24 EDT
Identified
Due to an issue with a provider we're experiencing delays and error with out Subscription purchase flow in GC.com.
Posted 21 days ago. Jul 02, 2019 - 09:59 EDT
This incident affected: Payments and Billing.