Game email alerts may be delayed
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted 8 months ago. Dec 15, 2018 - 18:08 EST
Update
We are continuing to work on a fix for this issue.
Posted 8 months ago. Dec 15, 2018 - 18:03 EST
Identified
Our email provider is experiencing issues, which is causing delays in our game email alerts.
Posted 8 months ago. Dec 15, 2018 - 18:03 EST
This incident affected: SMS and Email Alerts.