Degraded Performance of Team Manager Search
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted May 15, 2021 - 16:51 EDT
Investigating
Team Manager Search is experiencing performance issues. You may experience slow response times. Our engineers are investigating the cause of the issue.
Posted May 15, 2021 - 16:30 EDT
This incident affected: Team Manager App API.