Stat calculation delays
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 20:43 EDT
Investigating
Some game and player stats are calculating slowly. Our engineers are investigating the cause of the issue.
Posted Apr 20, 2021 - 19:04 EDT
This incident affected: GC.com, Baseball and Softball App API, and Stat Calculation.